Мои Конспекты
Главная | Обратная связь

...

Автомобили
Астрономия
Биология
География
Дом и сад
Другие языки
Другое
Информатика
История
Культура
Литература
Логика
Математика
Медицина
Металлургия
Механика
Образование
Охрана труда
Педагогика
Политика
Право
Психология
Религия
Риторика
Социология
Спорт
Строительство
Технология
Туризм
Физика
Философия
Финансы
Химия
Черчение
Экология
Экономика
Электроника

Программирование в Excel





Помощь в ✍️ написании работы
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой

А) Использование формул и функций

· Формулы применяются для вычислений с использованием арифметических операций (+,-,*,/,^ (возведение в степень)), встроенных функций fx и заданных величин на рабочем листе.

· Для адресации ячеек в формулах обычно используют относительные ссылки. При этом ссылки в формулах автоматически изменяются при копировании формулы в другие ячейки.

Например, если в ячейке В10 записана формула =СУММ(В3:В9), то при копировании этой формулы в ячейку С10 она преобразуется в =СУММ(С3:С9).

· Для того, чтобы ссылки в формуле не изменялись при копировании формулы в другую ячейку используют абсолютные ссылки, которые обозначаются знаком доллара $. Этот знак размещают перед номером строки или обозначением столбца:

$C$7- неизменяемый (фиксированный) столбец и строка;

$C7- фиксированный столбец;

C$7- фиксированная строка.

· Ссылки на ячейки из других рабочих листов:

Лист1!В29 – ссылка на ячейку В29 на листе 1.

· Ввод функций:

Выделить ячейку, в которую надо поместить функцию, щелкнуть ЛКМ на кнопке «Вставка функции fx». Указать нужный тип в списке «Категории», выбрать конкретную функцию из списка и щелкнуть на ОК. В палитре формул введите аргументы путем выделения нужных диапазонов.

· Список основных функций?:

=ОКРУГЛ(А40;0) – округляет число в ячейке А40 до указанного количества десятичных разрядов справа от десятичной запятой, если число разрядов равно 0, то до ближайшего целого;

=ЦЕЛОЕ(А10)- округляет число, содержащееся в ячейке А10 до ближайшего меньшего целого;

=СЛЧИС()- возвращает равномерно распределенное случайное число большее либо равное о и меньшее 1. Чтобы изменить случайное число надо нажать F9, для фиксации случайного числа: ПРАВКА Копировать Правка Специальная вставка Вставить значения Операция нет;

=СУММ(Е3:Е7*L3:L7)– перемножение и суммирование массивов. Для получения результата набрать «Ctrl+Shift+Enter»;

=СУММ(В1:В5^2)– возведение чисел в квадрат и суммирование результатов для массива данных;

=СУММЕСЛИ(D19:D25;”>=3,5”;E19:E25) – функция включает в суммирование те ячейки Е19:Е25, которые соответствуют ячейкам D19:D25, содержащим числа >= 3,5;

=СУММ(В52:G52*B49:G49^2) –функция суммирует ячейки массива -строки В52:G52 умноженные на данные, содержащиеся в ячейках массива-строки B49:G49 возведенные в квадрат;

=СЧЕТЕСЛИ(С42:С58;”>=0”)– функция подсчитывает количество ячеек внутри заданного интервала, удовлетворяющих критерию;

=ЕСЛИ(А42>=3; “Молодец“;“Плохо”) – функция записывает “Молодец” тогда, когда число содержащееся в ячейке А42 превышает или равно 3, в противном случае записывает “Плохо”;

=МУМНОЖ(Е55F56;H61:H62)– умножение матриц;

=МОБР(В55:С56) – получение обратной матрицы;

=МОПР(В55:С56) – определение значения определителя;

=ЕСЛИ(ЕЧИСЛО(С10);»Введено число»;»Введите число»).

Б) Фрагменты и технологии создания программ

Фрагмент программы экспертизы знаний:

· Входим в Excel.

· В ячейку А1 вводим текст вопроса: Установите фундаментальные принципы управления

· В ячейки А2:А8 вводим варианты ответов (ответы должны быть правильные и неправильные): Управление в функции пути; Управление в функции времени; Разомкнутое управление; Автоматическое управление; Управление по отклонению; Полуавтоматическое управление; Управление по возмущению;

· В ячейке В1 размещаем форматы ответов (0 – Нет, 1 – Да);

· В ячейки В2:В8 пользователь должен ставить ответы в виде цифр 0 или 1;

· В ячейку А9 вводим формулу:

=СЧЕТЕСЛИ(В2:В8;”=1”);

· В ячейку А10 вводим формулу:

=ЕСЛИ(И(А9<4;ЕЧИСЛО(В2:В8));(В4+В6+В8)*5/3;0);

· В ячейку А11 вводим надпись «Ваш рейтинг=»

· В ячейку А12 вводим формулу:

=ОКРУГЛ(А10;0);

· Организуем операции для скрытия строк с формулами и ограничения доступа к программе:

-Скрыть строки А9 и А10 (щелкнуть ПКМ на номере строки, которую хотите скрыть, выберите Скрыть из появившегося меню [ для отображения этих строк: выделить рядом лежащие строки, на одной из выделенных строк щелкните ПКМ, выберите «Отобразить»]);

- скрыть формулу в ячейке А12: Выделить А12 Формат Ячейки Скрыть формулы ОК (действует после защиты листа);

- защитить лист: выделить А1:А12, Сервис, Защита, Защитить лист, Пароль, ОК, Пароль, ОК). Внимание запомнить пароль!!!

Доверь свою работу ✍️ кандидату наук!
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой



Поиск по сайту:







©2015-2020 mykonspekts.ru Все права принадлежат авторам размещенных материалов.