Мои Конспекты
Главная | Обратная связь

...

Автомобили
Астрономия
Биология
География
Дом и сад
Другие языки
Другое
Информатика
История
Культура
Литература
Логика
Математика
Медицина
Металлургия
Механика
Образование
Охрана труда
Педагогика
Политика
Право
Психология
Религия
Риторика
Социология
Спорт
Строительство
Технология
Туризм
Физика
Философия
Финансы
Химия
Черчение
Экология
Экономика
Электроника

Условие решения задачи (проверка продуктивности матрицы)





Помощь в ✍️ написании работы
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой

 

Для того чтобы система уравнений (31) имела единственное неотрицательное решение при любом неотрицательном векторе Y, необходимо, чтобы матрица А была продуктивной. Экономический смысл продуктивности состоит в том, что существует такой план выпуска продукции, при котором каждая отрасль сможет произвести некоторое количество конечной продукции. Известно, что для продуктивности матрицы А³ 0 необходимо и достаточно, чтобы все главные миноры матрицы (Е - А) были положительными числами, строго меньше единицы. Кроме того, если сумма элементов каждого из столбцов неотрицательной квадратной матрицы А положительна и строго меньше единицы, то все главные миноры матрицы (Е - А) положительны и строго меньше единицы.

Очевидно, что с использованием матричных операций в Excel процедура вычислений в балансовой модели существенно упростится.

 

Реализация балансовой модели в электронной таблице

 

Компьютерная реализация балансовой модели в ЭТ показана в табл. 70 (режим показа формул в Excel), табл. 71 (показ формул в Calc) и в табл. 72 (режим вычислений).

В строке 11 размещены формулы для проверки продуктивности матрицы технологических коэффициентов. В ячейке А11 формула

=ИЛИ(В10>=1;C10>=1;D10>=1).

Проверяем содержимое ячеек В10:D10. Если хотя бы в одной из этих ячеек значение больше единицы (то есть сумма значений элементов хотя бы в одном столбце превышает единицу), то в ячейку А11 будет записано значение «ИСТИНА». В противном случае – значение «ЛОЖЬ»;

В ячейку С11 введена формула

=ЕСЛИ(А11=”ИСТИНА”;”Нет решения”;”Матрица продуктивна”).

Эта формула проверяет содержимое ячейки А11 и если сумма элементов хотя бы одного столбца превысила единицу, выводит сообщение “Нет решения”, в противном случае – “Матрица продуктивна”.

 

Таблица 70

  A B C D
БАЛАНСОВАЯ МОДЕЛЬ
Объём производства Потребление отраслей
Вычисление технологи-ческих коэффициен-тов =В4/А$4 =С4/А$5 =D4/А$6
=В5/А$4 =С5/А$5 =D5/А$6
=В6/А$4 =С6/А$5 =D6/А$6
Проверка продуктивности матрицы А
  =СУММ(В7:В9) =СУММ(C7:C9) =СУММ(D7:D9)
=ИЛИ(В10>=1;С10>=1;D10>=1) =ЕСЛИ(А11=”ИСТИНА”;"Решения нет"; "Матрица продуктивна")
Единичная матрица
Вычисление Е-А =В12-В6 =C12-C6 =D12-D6
=В13-В7 =C13-C7 =D13-D7
=В14-В8 =C14-C8 =D14-D8
Вычисление обратной матрицы =МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
=МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
=МОБР(В15:D17) =МОБР(В15:D17) =МОБР(В15:D17)
Спрос на будущий период План выпуска продукции =МУМНОЖ(В18:D20;В21:В23)
=МУМНОЖ(В18:D20;В21:В23)
=МУМНОЖ(В18:D20;В21:В23)

Таблица 71

  A B C D
БАЛАНСОВАЯ МОДЕЛЬ
Объём про- изводства Потребление отраслей
Вычисление технологиче-ских коэф-фициентов =В3/А$3 =С3/А$4 =D3/А$5
= В4/А$3 =С4/А$4 =D4/А$5
= В5/А$3 =С5/А$4 =D5/А$5
Проверка продуктивности матрицы А
  =SUM(B6:B8) = SUM (C6:C8) = SUM (D6:D8)
=OR(B10>=1;C10>=1;D10>=1) =IF(A11=ИСТИНА;"Решения нет";"Матрица продуктивна")
Единичная матрица
Вычисление Е-А =B12-B6 =C12-C6 =D12-D6
=B13-B7 =C13-C7 =D13-D7
=B14-B8 =C14-C8 =D14-D8
Вычисление обратной матрицы =MINVERSE(B15:D17) = MINVERSE (B15:D17) = MINVERSE (B15:D17)
= MINVERSE (B15:D17) = MINVERSE (B15:D17) = MINVERSE (B15:D17)
= MINVERSE (B15:D17) = MINVERSE (B15:D17) = MINVERSE (B15:D17)
Спрос на будущий период План выпуска продукции =MMULT(B18:D20;B21:B23)
= MMULT (B18:D20;B21:B23)
= MMULT (B18:D20;B21:B23)
           

Таблица 72

  A B C D
БАЛАНСОВАЯ МОДЕЛЬ
Объём производства Потребление отраслей
Вычисление технологических коэффициентов 0,417 0,1 0,2
0,25 0,5
0,3 0,5
Проверка продуктивности матрицы А
  0,667 0,900 0,700
ЛОЖЬ Матрица продуктивна
Единичная матрица
Вычисление Е-А 0,583 -0,1 -0,2
-0,25 0,5
-0,3 0,5
Вычисление обратной матрицы 2,113 0,930 0,845
1,056 2,465 0,423
0,634 1,479 2,254
Спрос на будущий период План выпуска продукции 8619,72
8309,86
10985,92

 

Доверь свою работу ✍️ кандидату наук!
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой



Поиск по сайту:







©2015-2020 mykonspekts.ru Все права принадлежат авторам размещенных материалов.